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Introduction
This document will provide a hands-on tutorials demonstrating the ADF-GUI. Its purpose is to give a quick
tour of the main features of the ADF-GUI.

The first three tutorials provide an overview over all ADF-GUI modules. If you are new to the ADF-GUI, we
advise you to study the tutorials in the order presented. The other tutorials are intended to focus on one
particular feature of the ADF-GUI, or some particular application.

We estimate that you will need about half an hour for each part of the tutorial, for reading and performing the
hands-on activities.

The first three tutorials are also available as videos. The current videos are actually the tutorial videos for
ADF2009, so there will be minor differences with the ADF2010 GUI tutorials.

Additional information may be found in the ADF-GUI Reference manual

Remark: some keyboard shortcuts for menu commands used in the tutorials are platform specific. For
example:

• Undo: Ctrl-Z on Linux/Windows, Command-Z on Macintosh
• Save: Ctrl-S on Linux/Windows, Command-S on Macintosh

In general, on Linux and Windows machines use the Control key to access these shortcuts for the menu
commands, on a Mac use the Command key.

If you are using a Mac, the ADF-GUI uses the X11 program to run. The X11 program itself may intercept the
menu-shortcuts like Cmd-C, Cmd-H, and so on. You can change this using the Preferences command from
the X11 menu (Enable key equivalents under X11 should NOT be checked).

ADF-GUI modules

The ADF-GUI is the Graphical User Interface for the ADF package. It consists of several modules:

ADFjobs

This utility ($ADFBIN/adfjobs) manages your ADF jobs: run a job on your local machine or on remote
machines. It also serves as a interface to all files belonging to your job, and it serves as a convenient
launcher of the other ADF-GUI modules.

ADFinput

ADFinput ($ADFBIN/adfinput) helps ADF users to easily create ADF jobs. You can use ADFinput to
define your molecule (geometry), pre-optimize it, and to set details of your ADF job using an easy-to-
use graphical user interface. ADFinput will generate the basic job script for you. This script takes care of
running ADF and property programs as required.

ADFview

ADFview ($ADFBIN/adfview) displays volume data, such as electron densities, orbitals, electrostatic
potentials and more. You can also use it to visualize scalar atomic data like charges.

ADFmovie

ADFmovie ($ADFBIN/adfmovie) follows geometry steps as performed by ADF during geometry
optimizations, IRC calculations, etc. It can be used during the calculation to monitor the progress (based
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on information from the logfile), or it can be used to analyze the geometry changes after a calculation. It
is also used to display normal modes calculated with a frequency calculation.

ADFlevels

ADFlevels ($ADFBIN/adflevels) generates a diagram showing the energy levels of a finished
calculation. You can interact with it: show an interaction diagram (how the molecular orbitals are
constructed from fragment orbitals), show labels, occupations, orbitals, etc.

ADFdos

ADFdos ($ADFBIN/adfdos) shows DOS and GPDOS for ADF results. You can easily select which
partial DOS to show by selecting atoms, and you can even select to show the GPDOS for select atoms
and L-shells.

ADFspectra

ADFspectra ($ADFBIN/adfspectra) shows spectra calculated by ADF. It can show IR, Raman, excitation
and CD spectra, as well as a DOS plot. For some spectra it can also perform additional tasks (using
other ADF-GUI modules), like displaying normal modes or orbitals.

ADFtail

ADFtail ($ADFBIN/adftail) shows the contents of a text file, updating when the text file grows (like the
UNIX tail -f command). It is used to monitor the 'logfile'. The progress of an ADF calculation is always
written to this file.

ADFoutput

ADFoutput ($ADFBIN/adfoutput) shows the output of ADF (or any other text file). It will analyze the
output and provide quick links to sections of interest.

GUIprefs

GUIprefs ($ADFBIN/guiprefs) allows you to adjust and save numerous GUI preferences, such as color
schemes, environmental variables, etc. The preferences will be used by all ADF-GUI modules.

All ADF-GUI modules have the SCM menu on the left-hand side, on most systems represented by a small
SCM logo. Using the SCM menu commands you can easily switch between the different modules of the
ADF-GUI.

Starting the ADF-GUI modules

We will assume that you have installed the ADF package on your machines.

Depending on your platform, you start the ADF-GUI modules in a slightly different way:

UNIX (such as Linux) users

In this tutorial we will assume that you have added $ADFBIN to your PATH. We advise you to do this if you
have not already done so. If you do not wish to add $ADFBIN to your PATH, you must start the utilities using

$ADFBIN/adfjobs &

instead of just
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adfjobs &

On all UNIX platforms, including Mac OS X, the ADF-GUI programs are XWindow (X11) programs. Your
environment should have been set up correctly to run such programs. In particular, you need to make sure
that your DISPLAY environment variable has been set properly.

You can test this easily by starting a simple X program from your shell:

xcalc &

Assuming the xcalc program is in your $PATH, a small window should appear with the image of a calculator.
If not, please consult your local system administrator for additional help. Typical problems have to do with
your DISPLAY variable, and with security issues when trying to connect to the X server.

Windows users

In this tutorial we will assume that you have installed the ADF package using the Installer with all the options
set to default.

You can start the ADF-GUI (adfjobs) by double-clicking its icon on the desktop.

Macintosh users

Macintosh users have several easy ways of starting the ADF-GUI modules: just like on any other UNIX
system (thus, using the command line), or using the ADFLaunch program.

The easiest way is using the 'ADFLaunch' program. When you start it, ADFjobs will be started automatically.
Next you can use the SCM menu to start the other ADF-GUI modules.
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ADF-GUI overview tutorials

Tutorial 1: Geometry optimization of ethanol

This tutorial will help you to:

• create a simple molecule
• view the molecule from all sides and save a picture
• make a couple of changes to the molecule with different tools
• set up your ADF calculation
• perform the actual ADF calculation
• visualize some results: energy levels, geometry, electron density, orbitals, ...

Step 1: Preparations

Start ADFjobs

On a Unix-like system, enter the following command:

cd
adfjobs &

On Windows, one can start ADFjobs by double-clicking on the ADF-GUI icon on the Desktop:

double click the ADF-GUI icon on the Desktop

On Macintosh, use the ADFLaunch program to start ADFjobs:

Double click on the ADFLaunch icon
Make sure X11 allows you to use keyboard shortcuts (you only need to do this
once):

Press Cmd-,
If nothing happens everything is fine.
If the X11 Preferences dialog appears:

uncheck the "Enable key equivalents under X11" check box and close
that dialog.
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Make a directory for the tutorial

We prefer to run the tutorial in a new, clean, directory. That way we will not interfere with other projects.
ADFjobs not only manages your jobs, but also has some file management options. In this case we use
ADFjobs to make the new directory:
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Select the File → New Directory command (thus, the New Directory command from the
File menu)
Rename the new directory by typing 'Tutorial' and a Return

Change into that directory by clicking once on the folder icon in front of it
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Start ADFinput

Now we will start ADFinput in this directory using the SCM menu:

Select the SCM → ADFinput menu command:
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use the SCM menu on the top left (the SCM logo on most platforms),
next select the ADFinput command from the menu.

The ADFinput module should start:

The ADFinput window consists of the following main parts:

• the menu bar with the menu commands
• the drawing area of the molecule editor (the dark area on the middle left side)
• the status field (lower part of the dark area, blank when the ADFinput is empty as shown above)
• the molecule editor tools
• many panels with several kinds of options (currently the 'Main Options' panel is visible)

Undo

ADFinput has an Undo command, which works on your molecule (thus not on your input options).
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If you make a mistake while making changes to your molecule, just use the Edit → Undo menu command to
go back in time. You can Undo more than one step, or Redo a step (with Edit → Redo) if you wish to do so.

Step 2: Create your molecule

Create a molecule

The molecule we are going to create is ethanol.

First we will draw the two carbon atoms, next the oxygen atom, and after that we will add all hydrogen atoms
at once. Finally, we will pre-optimize the geometry within ADFinput.

Create the first carbon atom

To create an atom, you need to select an atom tool.

Select the C-tool by clicking on the button with the 'C'

Back glow is added to the 'C' button to indicate that you are using the C-tool. Also, the status field in the left
bottom corner shows 'C tool, create single bond' to indicate that you are using the C-tool.

Now create the first carbon atom:

Click somewhere in the drawing area
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One carbon atom has been created.

Note that:

• If you move the mouse you will see a white line from that carbon atom to the current mouse
pointer position: this shows you are in 'bonding' mode, and that the bond will be made to the atom
just created.

• The 'C' button has a different color, indicating you are still using the C-tool.
• The carbon atom is selected (the green glow), which indicates that the carbon atom is the current

selection.
• The status field contains information about the current selection: it is a Carbon, number 0, with 4

'connectors'
• The status field also shows the current tool (C), and that a single bond will be made.
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Create the second carbon atom

Click somewhere in the drawing area to create the second carbon atom

A second carbon atom has been created, bonded to the first atom.

The atom will be created along the 'bonding line', at a distance that corresponds to a normal C-C single
bond distance. That is, the bond length is constrained while drawing.

The newly created atom becomes the new selection, and you are still in bonding mode. The next bond will
be created to the carbon atom just created. And you are still using the C-tool.
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Create the oxygen atom

To create the oxygen atom you need to switch to the O-tool:

Select the O-tool by clicking on the button with the 'O'

With the O-tool, create an oxygen atom bonded to the second carbon;

Click somewhere in the drawing area

The oxygen atom has been added.

For now, we are done using atom tools, so go back to the select tool:
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Select the select-tool by clicking on the button with the arrow

Add the hydrogens

Now many hydrogen atoms need to be added. You can do this using the H-tool, but a much easier method
is to use the Atoms → Add Hydrogen menu command:

The 'Add Hydrogen' menu command works on the selection only, when present. Thus, only one hydrogen
atom would be added to the oxygen atom. This is not what you want. So first we make sure that nothing is
selected by clicking in empty space.

Click in empty (drawing) space

Now no atoms are selected any more.

Select the Atoms → Add Hydrogen command

Many menu commands have shortcuts. In this case you can also use the shortcut (Control-H or Command-
H, depending on your platform) as an alternative. The shortcuts are indicated in the menu commands.
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All atoms will be saturated with hydrogen atoms. And you have created an ethanol molecule, though the
geometry is still far from perfect.

Pre-optimize the geometry

Now use the optimizer that comes with ADFinput to pre-optimize the geometry.

Click on the pre-optimizer button (the rightmost 'gear wheel' button of the
menu bar)
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The geometry of the molecule will be pre-optimized very quickly, using a simple (and inaccurate) force field
method.

In the status field below the drawing area you can follow the pre-optimization iteration number and the
energy relatively to the starting configuration.

Viewing the molecule

Rotate, translate, or zoom

You can rotate, translate, and zoom your molecule using the mouse.

You need to drag with the mouse: press a mouse button, and while holding it down move it. Which mouse
button, and which modifier key you press at the same time, determines what will happen:

Rotate Left
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Rotate in-plane Ctrl-Left
Translate Middle, or Alt-Left
Zoom Mouse wheel, Right, or Command-Left (drag up or down)

The rotate, translate, and zoom operations change how you look at the molecule, they do not change the
coordinates.

Click once somewhere in empty space to make sure nothing is selected.

Click with the left mouse button, and drag:
your molecule will rotate.

Click with the left mouse button with the ctrl-key, and drag:
your molecule will rotate in-plane.

Click with the middle mouse button (or left with alt-key), and drag:
your molecule will be translated.

Click with the right mouse button (or left with command key), and drag up and
down:
you will zoom closer to or away from your molecule.

Use the mouse wheel, if you have one:
you will zoom closer to or away from your molecule.

Using all these options, try to position the ethanol as closely as possible as
in the
following image:
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Atom colors

The atoms of your molecule will have a pre-defined color, as visible in the molecule editor. You can change
these colors in two ways: either change the global default color per element, or override the default color for
a specific atom. The first method uses the GUIprefs module, the second method uses the 'Atom Details
panel' via the Atoms → Details (Color, Radius, Mass, ...). In this tutorial we will change the default color of
all Carbon atoms using the GUIprefs module:

Open the GUIprefs module by using the SCM → Preferences menu command
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In the GUIprefs module, go to the 'Atom Colors' panel (use the pull-down menu
on top).
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Click on the '+' button, and select C (Carbon) from the periodic table that
pops up.

You can now change the color for the carbon atoms either by clicking on the colored block next to the C
label

Click on the colored C-block
Select your favorite color, and dismiss the Color dialog (click the OK button
on most platforms)
Click the Preview button in the bottom of the GUIprefs panel.
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In ADFinput the colors of the carbon atoms will now be adjusted to the color that you have selected.

The 'Preview' button shows the effect of your new preferences in all open GUI modules, but without saving
them. Once you are content with your changes, you can use the 'Save' button to store the new defaults.

If you quit the GUIprefs module without saving, your original settings will be restored (also in the open
modules).

To revert to the default value of carbon, you can remove the carbon color in GUIprefs by pressing the -
button in front of the C color line:

Click the '-' button in front of the C color line
Click the 'Preview' button
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In ADFinput, your carbon atoms now should have their default color again (dark grey).

Use the FIle → Quit menu command to close the GUIPrefs module

Save picture

You can save a picture of your molecule using the 'Save Picture ...' command from the File menu.

25



The default format used is the PNG format. You can change this using the File → Default Picture Format
menu command. You can also change the resolution. A smaller resolution will result in a smaller file, but will
reduce the quality.

Select the File → Save Picture ... command
Enter the name for your picture: ethanol
Click the 'Save' button

A picture will be saved to disk containing the image of your molecule. Only the drawing area is saved in the
picture, not all the input options.

Molecular conformation

Rotate such that you look along the C-C axis

Rotate your molecule into the following position:
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Select the top CH3 group

Click once on the top carbon atom
Use the Select → Select Connected menu command
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As you will notice, all atoms directly connected to the selected atom are added to the selection. Alternatively,
you can also make a selection by shift-clicking on the elements you want to select.

Click in empty space
Click on the top carbon atom
Shift-Click once (without moving) on each of the top hydrogen atoms

This has almost the same effect (in this case you have not selected the second carbon atom).

Rotate the selection

We are now trying to make an eclipsed geometry.

Ctrl-Click with the left mouse button on one of the selected hydrogens,
and drag around to rotate the selection in-plane.

Rotate the hydrogen atoms in an almost eclipsed position.
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You can move the selection by clicking on a selected object, and dragging with the mouse. All usual
operations are possible: rotate, rotate in-plane, translate and zoom. Zoom in this case means moving the
selection perpendicular to the screen.

In the status field you see the current rotation angle.

You have to click and start dragging on a selected item. If you click and drag in space you will move the
entire molecule.

Back to Staggered Geometry

Click in empty space to clear the selection
Click on the pre-optimize button

The optimizer will bring the structure back to the original staggered geometry. If it does not complete, repeat
this step until it does.

29



Getting and setting geometry parameters

Bond length

First select the oxygen atom and the connected hydrogen atom.

This time we make the selection by dragging a rectangle around all objects that we want to select.

Using the left mouse button together with the shift key, drag a rectangle
around the oxygen and hydrogen atom.

Release the mouse button (and the shift key)

The oxygen atom and the hydrogen atom are selected.
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In the status area you see the distance between the selected atoms, and information about the bond.

You can set the distance to any value you wish by editing it, or by pressing the tiny buttons next to the
distance.

Click and hold a short time on the upper tiny button next to the distance

Bond angle

Select first one of the top hydrogens by clicking on it
Next, extend the selection (shift key) by clicking on the top carbon atom
Finally, extend the selection (shift key) by clicking on another top hydrogen
atom
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In the status area information about the bond angle of the selected three atoms is given. You can change
this value to a value you like.

Dihedral angle

By selecting four atoms we get information about the dihedral angle. And of course you can also change it.

Move the molecule such that you can see all atoms
Select first one of the top hydrogens by clicking on it
Next, extend the selection (shift key) by clicking on the top carbon atom
Next, extend the selection (shift key) by clicking on the next carbon atom
Finally, extend the selection (shift key) by clicking on the oxygen atom
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Coordinates

To view the coordinates we have to go to a different input panel. The input panels can be selected with the
pull-down menu on the top of the input panels on the right side.

In the right side of the ADFinput window:
click and hold on the pull-down menu on the top, currently named 'Main Options'

Select the Coordinates panel (at the top of the right column)
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You get a list of all Cartesian coordinates. They will be updated in real time when you make changes to the
molecule, and you can also edit the values yourself. In that case, the picture of the molecule will be updated
automatically.

Note that some atoms are highlighted. These are the currently selected atoms.

The 'Move Atom(s)' buttons will move the selected atoms up or down. In this way you can re-order the
atoms.

You may, in some cases, wish to revert to Internal coordinates. These will be updated in real time as well,
and you can also edit the values yourself. If you re-order the atoms while using the Internal coordinates, the
matrix will be recalculated from scratch.
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Make sure you have Cartesian coordinates selected

Extending and changing your molecule

Before making some changes, let's re-optimize. We first select the 'Main Options' panel so the coordinates
will not be visible during the pre-optimization. Otherwise this may slow down the pre-optimization.

Select the 'Main Options' panel
Click on the pre-optimize button

Let's try to change the CH2OH group in a COOH group.

Thus, we need to:

• remove one hydrogen
• change one hydrogen into an oxygen
• change a single bond into a double bond

After this, we will revert to the ethanol molecule.

Delete an atom

First: delete one hydrogen

Click in empty space to clear the selection
Click once on the hydrogen to delete, it will be selected
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Press the backspace key
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The selected atom is removed.

Change the type of an atom

Next, we will change a hydrogen into an oxygen atom

Select the O-tool
Double-click on the hydrogen that should change into an oxygen
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Change the bond type of an existing bond

Now the oxygen atom is singly bonded to the carbon, we need to change this into a double bond.

Click on the bond between the carbon and the new oxygen
Use the Bonds → Bond Order → Double menu command
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The single bond has changed into a double bond.

Another way to modify a bond type is to click on the bond once which will select this bond. Then click on the
bond tool in the menu bar ('ball and stick' logo to the right of the start), and select the proper bond type.

The fastest way to change the bond order is to use the keyboard shortcuts. If you have selected a bond,
press 1 for a single bond, 2 for a double bond, 3 for a triple bond and 4 for an aromatic bond.

To get a reasonable geometry optimize the structure:

Click in empty space to deselect the bond
Press the pre-optimize button
If not converged, press pre-optimize again
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Add new (bonded) atoms

Now, to revert to the ethanol molecule, we first remove the new doubly-bonded oxygen atom, and then add
one hydrogen atom.

Click once on the doubly-bonded oxygen atom to select it
Press the backspace key to delete it

Select the H-tool
Click once on the carbon atom connected to the oxygen
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Note that this way you started bonding mode again, as indicated by the bond to the mouse position.

Click once in empty space to make a hydrogen atom (connected to the carbon!)
Click once on the just created atom to stop bonding

Repeat this to add a second hydrogen to the carbon atom

Pre-optimize the molecule
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Once again you have created an ethanol molecule.

Step 3: Select calculation options

Preset

You should always start by choosing the proper preset.

ADF has many different modes of operation. ADFinput presents the correct settings for some common
calculations together as 'presets'.

So to optimize the geometry of the ethanol molecule we choose the proper preset:

Select the 'Geometry Optimization' preset from the 'Preset' menu.
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Presets might change any number of input options. In this particular example, the main Task will change
from 'Single Point' to 'Geometry Optimization'. You can easily see what fields have been updated by a
preset: they are colored green.

If you would use this preset again later, the input values that are set by this preset will revert to the default
values. If you made changes to those fields you will loose those changes.

Title

This field, currently empty, has no special meaning for the calculation routine. It will be used as an identifier
for your convenience in the result files of the ADF calculation. In this case, let's set the title to the name of
the molecule:

Enter 'Ethanol' without quotes in the 'Title' field.
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Note that as soon as you start typing in the title field, the color of the field changes to yellow. The yellow
color here and in other cases indicates that you have made a change with respect to the default value for
this field.

XC functional

An important input option is the XC functional to use.

For this tutorial the default simple (and fast) LDA potential during the SCF is sufficient. So just leave this at
the default value

By selecting the LDA+GGA+METAGGA option for the xc energy ADF will print a table at the end of the
calculation showing the energies with many different functionals:

Select the 'LDA+GGA+METAGGA' option for the xc energy after SCF
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Again, since you made a change with respect to the default value the change is highlighted with a yellow
color.

Basis set

With the 'Basis Set' pull-down menu you select the basis set you want to use.

The menu gives access to the basis sets regularly used.

For this tutorial we will choose a very small basis set. This will result in poor results, but the calculation runs
much faster. Thus:

Select 'SZ' from the 'Basis Set' pull-down menu
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Integration

The ADF software package uses a numerical integration scheme for virtually everything it may calculate.
The number specified here is roughly the number of significant digits in your results. If you leave the field
blank ADF will select a reasonable default value.

Increasing the number makes the results more accurate, but will require substantially more computation
time. Similarly, decreasing the number will result in less accurate results, but you will get the results faster.

For the tutorial, we will reduce the accuracy in order to speed things up:

Set the integration accuracy to 3.0.

46



The color of the field changes to yellow to warn you that you changed a field.

Other input options

On the right side of the window you will find many more input fields. They are organized in panels. You
select a panel with the pull-down menu showing the title of the panel, along the topside.

47



Note that the menu items also use a color coding to show you which panels have been affected by a preset
(green), by the user (yellow), or both (red).

As we will not do anything special right now, you do not need to change anything in other panels.
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Step 4: Run your calculation

Save your input and create a job script

Finally you will want to save your input.

Select the File → Save command.

Enter the name 'ethanol' in the File name field.

Click on Save

ADFinput will now present a warning dialog:

So the requested option to print meta-GGA results after the final SCF will produce incorrect results when
using frozen cores. Normally you will not accept this, for the tutorial lets just continue with this set-up:
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Click OK to dismiss the warning dialog

A new dialog pops up asking you if you really want to save the run script even though it will not be correct:

The run script will not be correct because we use the frozen core option together with metaGGA's, as we
were told before. Accept this and save it anyhow:

Click Yes to save the run script

Now you have saved your current options and molecule information. The file will automatically get the
extension '.adf'.

ADFinput has also created a corresponding script file. This script file has the same name, but with an
extension '.run' instead of '.adf'.

In the ADFjobs module you can see what files have been created:

Click once in the ADFjobs window to activate it
Click once on the triangle in front of the name of the job (ethanol)

You will see the .adf and .run files, and a .pid file that ADFjobs uses to store information. You might also see
the picture that you saved, if you used the name 'ethanol' for it. Only the extensions are listed, so the real file
names are ethanol.adf, ethanol.run and ethanol.pid. Notice the job status icon (the open circle on the right)
that ADFjobs uses to indicate a new job.

Run your calculation

To actually perform the calculation (the geometry optimization of the ethanol molecule), use the Job → Run
menu command in ADFjobs:
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Make sure the ethanol job is selected in ADFjobs (it is if you followed the
tutorial)
Select the Job → Run command

This will execute the run script that has just been created. If you have never made changes in the ADFjobs
setup, the default behavior is to run the job in the background on your local computer, using the Sequential
queue. This queue will make sure that if you try to run more then one job at the same time, they will be run
one after another.

Once your job starts running, ADFjobs will open ADFtail to monitor the progress of the calculation (the
logfile):
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While running the job status symbol in ADFjobs changes:
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Step 5: Results of your calculation

Logfile: ADFtail

The logfile is saved and extended by ADF as it it running.

Right now it is already showing in the ADFtail window, but you could have used any text editor.

Now wait for the calculation to finish:

Wait until ADFtail shows 'Job ... has finished' as last line
In the dialog that pops up, click 'Yes' to update the geometry

Now close ADFtail by using the File → Quit menu command:

In the window showing the logfile (the ADFtail window):

Select the File → Quit command

In the ADFjobs window, note that the job status icon has changed to indicate that the job is ready:

Files

ADF has created a couple of data files and a couple of text files. You can check this in the ADFjobs window:
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Click on the ADFjobs window

Note that the Local files are visible because earlier in the tutorial you already clicked on the triangle opening
the details for this job.

The .adf file is the input as saved by ADFinput.

The .run file is the run script, also saved by ADFinput.

To enable specific options of your ADF job, changes to the text of the .run script can be made opening it via
double-click. A separate text editor window pops up after the double-click (the non-default text editor
program can be defined via the $EDITOR variable passed to ADF-GUI). When you run your job, your edited
.run file will be used. Note that when you save your input via ADFinput again, your .run file will be
overwritten (and thus you loose any changes you made when editing the .run file).

The .job file is a script file based on the .run file, and is created by ADFjobs. It contains all commands
required to run your job, and is actually run by ADFjobs when you use the Run command.

The .pid file is a file that contains your job status and configuration. It is used by ADFjobs.

The other files are produced by ADF. The .err file contains error messages, the .logfile shows the progress
of the calculation, the .out file is the main (text) output file, and the other files are binary files that store
results of the calculation.

Geometry changes: ADFmovie

ADF has optimized the geometry, and we can use the ADFmovie module to visualize the progress of the
optimization. So let's start ADFmovie:
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Select the SCM → Movie command in ADFinput

The ADFmovie module will display a movie of the geometry optimization.
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To step through the different geometries, use the slider below the picture. Clicking in the slider will single
step through the frames. Or you can grab the slider and move to the frame you wish. Or you can use the left
and right arrow keys to single step through the frames.

You can control playing with the buttons. When your mouse pointer is above any of the buttons, and not
moving, a balloon will pop up showing what that particular button will do.

It is often nice to have a graph of the energy as function of the geometry step. ADFmovie can show such
graphs easily:

Use the Graph → Energy menu command
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You can even show several graphs for different properties at the same time:

Use the Graph → Add Graph menu command
Select two carbon atoms by shift-clicking on them
Use the Graph → Distance, Angle, Dihedral menu command

Now you have two graphs. One of them is the 'active' graph. When you make a new graph it will always be
the active graph. You can also make a graph active by clicking on it.

When you select a property from the Graph menu (Energy, Distance and so on) that property will be plotted
in the active graph.

You can also multiple curves in one graph, if possible: one property per Y axes. You may have several
curves on the same Y axes if they are using the same unit (all Angstroms for example):
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Select two carbon atoms and one oxygen atom by shift-clicking on them
Use the Graph → Distance, Angle, Dihedral menu command

Another feature is that you can click on a point in one of the graphs. It will be marked, the movie will jump to
that particular step, and if you have more then one graph the corresponding point(s) will also be marked in
the other graphs.

To rotate, translate, or zoom the picture, use your mouse, just as in ADFinput.

Use the slider to go to a frame in the middle of the optimization

Selecting atoms provides information about atoms, bonds, etc. The information will be updated when you go
to another point in the movie (a different geometry). You can see examples of these in the pictures above.

You can also show this information in the 3D window:

Use the View → Geometric Info → Angle menu command
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The angle will be visually added to your molecule :
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In the ADFmovie window: select File → Quit

Orbital energy levels: ADFlevels

Select your job in the ADFjobs window by clicking on the job name
Select the SCM → ADF Levels command

ADFlevels will start and show a diagram of the energy levels of the ethanol molecule.
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In the diagram you can see from what fragment types the molecular levels are composed.

Move the mouse around, above different levels, without clicking

Balloons will pop up with information about the level at the mouse position.

Click and hold on the HOMO level of the molecule
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In the pop-up that appears, select 'Show Labels'

Click and hold on the HOMO of the O fragment type
In the pop-up, select 'Show Labels'

To actually see the orbital, select the orbital from the top of the pop-up menu:

Click and hold on the HOMO level of ethanol
Select the '10A' command

A window with a picture of the orbital should appear.

62



You can move (rotate, translate and zoom) the orbital with your mouse.

In the window with the orbital: select File → Quit
In the window with the levels: select File → Quit

Electron density, potential and orbitals: ADFview

Select SCM → View

ADFview will startup and show a picture of your molecule:
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You can use ADFview to visualize all kinds of 'field' related properties: densities, orbitals, potentials, etc. You
actually have already used it before: the picture of the orbital that was created using ADFlevels was shown
by ADFview.

Use the mouse to rotate, translate or zoom, as in ADFinput.

Select the Add → Isosurface: Colored command

Below the picture a control line will be created. ADFview creates one such line for all visual items and
special fields (surfaces, cut planes, calculated fields, etc.) that you add.

In this particular case the control line contains two pull-down menus that you use to select the fields that you
want to visualize.

From the first pull-down menu in the control line, select Density → SCF

From the second pull-down menu in the control line, select Potential → SCF
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To demonstrate some other possibilities of ADFview, do the following:

Select the Add → HOMO command
Click on the check box in the FIRST control line to hide the density

Select the Add → Cut plane: Colored command
In the new control line, press on the pull-down menu and select Density → SCF
Rotate your molecule to get a good view
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Select the Fields → Grid → Medium command
Click Yes to recalculate the fields

You can save the picture you create using the Save Picture menu command:

Select File → Save Picture ...
Enter the name (without extension) of the file you want to create
Click Save

A picture with the (file)name you specified has been created.

You might want to explore some more of the possibilities of ADFview on your own. Many different properties
can be visualized as you probably have noticed in the pull-down menus. Just do not activate Anti-Alias: it
makes the pictures even better, but also slows down ADFview very very much.

When you are done, close the ADFview window:

Select File → Quit

Browsing the Output: ADFoutput

The output file (tutorial.out) is a plain text file. You can view it with your favorite text editor (or text viewer).
You can also use the ADFoutput GUI module which provides a convenient way to check the results:
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Select the SCM → Output command
Select the Iterations → Geometry Cycles command

The ADFoutput program will start showing the results of your calculation, and via the menu you jumped to
the first section with geometry details:

You can use the menus to go to different parts of the output file, or you can just use the scroll bar. If a menu
option is shaded, this means that no corresponding section of the output is available.

Clicking an output section title highlighted in blue will skip to the next section with the same title, if present.
Have a look, and then close the program.

Select the SCM → Close All command in any ADF-GUI window

All open windows from the ADF-GUI will be closed.
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Tutorial 2: Excitation energies of ethene

First you will construct an ethene molecule and optimize its geometry. As this is basically the same
procedure as in Tutorial 1, only short instructions will be given.

Next you will set up the calculation of excitation energies, and let ADF perform the calculation.

Finally, using ADFlevels, ADFspectra and ADFview, you will examine the results.

Step 1: Start ADFinput

For this tutorial we again prefer to work in the Tutorial directory.

You know how to start ADFjobs (in your home directory), and move to the Tutorial directory:

cd $HOME
Start adfjobs
Click on the Tutorial folder icon

Next start ADFinput using the SCM menu. Notice that currently no job is selected. If a job is selected, the
SCM menu will open the selected job, which is not what we want at this moment.

You can toggle the selection in ADFjobs using the right mouse button (or control-left).

To clear the selection there are several options:

• press Esc,
• or click anywhere in the search bar on the bottom (except in the input fields),/li>
• or click in empty space,
• or click somewhere on the selected job (but not in an input field or an icon).

Make sure no job is selected in ADFjobs (hit ESC)
Select the SCM → ADF Input command

Step 2: Create your ethene molecule

First we construct an ethene molecule, and pre-optimize its geometry:

Select the C-tool by clicking on the button with the 'C'
Select the Double bond mode Bond tool → Double

(or use the shortcut: press the '2' - key)
Click somewhere in the drawing area to create a carbon atom
Click again to create a second carbon atom (with a double bond)
Select the select-tool by clicking on the button with the arrow
Click once in empty space so nothing is selected
Select the Atoms → Add Hydrogen command
Click the optimizer button

Your ethene molecule should look something like this:
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Step 3: Optimize the geometry

The next step is to optimize the geometry using ADF:

Enter a proper title in the Title field (like 'Ethene')
Select the 'Geometry Optimization' preset
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With the proper options selected, now run ADF:

Select the File → Run command
Click 'Yes' in the pop-up to save the current input
In the file select box, choose a name for your file
(for example 'ethene') and click 'Save'

Now ADF will start automatically, and you can follow the calculation using the logfile that is automatically
shown.

Wait until the optimization is ready (should take very little time)

The following dialog should appear:
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Click 'Yes' to update the coordinates

Step 4: Calculate the excitation energies

Select calculations options

To set up the calculation of the excitation spectrum:

Adjust the title to something like 'Ethene excitations'

Select the 'Single Point' template

Select the 'Excitations, CD' panel (use the pull down menu)
For the 'Type of excitations' option, Select 'Singlet and Triplet'
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Run the calculation

Now everything is ready to actually run ADF. Before running we will save the current input in a different file
(though this is not really required):

Select File → Save As...
Enter a filename (ethene-exci) and click 'Save'
Select File → Run
Wait for the calculation to finish
Click 'No' when asked if you wish to update the coordinates
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Step 5: Results of your calculation

Logfile: ADFtail

The logfile shows you that the calculation has finished, and that indeed the excitation code has been
running:

Energy levels: ADFlevels

Select SCM → Levels
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In this level diagram you can see that the HOMO and LUMO consist mainly of carbon p orbitals. It is also
easy to see what orbitals the hydrogens take part in.

Note that the carbon and hydrogen stacks show all carbon and hydrogen atoms at once: they show the
fragment type. ADFlevels can also show the individual fragments but when using atomic fragments you will
get too many fragments. In this particular case symmetry is used, and since there is only one symmetry
unique carbon atom and only one symmetry unique hydrogen atom you still would see only one stack per
atom type.

Excitation spectrum: ADFspectra

Select SCM → Spectra

ADFspectra will start and show the calculated excitation spectrum.
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When moving the mouse above a peak a pop-up will give you more information about that peak:

Move the mouse above the largest peak and hold it there

The composition of the excitation in terms of orbital transitions is listed in the pop-up. If you move the mouse
inside the pop-up and click on a line the corresponding orbitals will be shown using ADFview:

Move the mouse inside the pop-up and click on the line with the major
contribution
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Transition density: ADFview

You can use ADFview to view orbitals etc, but also to have a look at the transition density. At this moment
ADFview cannot generate this field automatically, it needs to be calculated first using DENSF. The ADFinput
defaults are such that if you perform an excitation calculation, DENSF will automatically calculate the
corresponding transitions densities. So we will start ADFview and next load the .t41 file generated by
DENSF:

Select SCM → View
Select File → Open
In the file-select pop-up, choose to see all .t41 files using the pop-up menu
at the bottom
Select the .t41 file from your calculation (ethene-exci.t41)
Click 'Open'
Select Add → Double Isosurface

In the field pull-down menu (in the control bar for the double isosurface) you will now find an entry 'Transition
Density', and if you select that you will find all transition densities that are available.
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In this case lets select the transition density that belongs to the biggest peak: the Singlet-Singlet 1B3u
excitation:

Select the Transition Density → TransDens_SS_B3.u_Fitdensity_1 field
Change the isovalue to 0.003
Rotate the molecule a little

77



The resolution is rather coarse, you can use interpolation to get a better picture. Or you can set the default
grid to use to Medium (in ADFinput in the 'Densities, Potential, Orbitals' panel).

ADF Output

Using the output browser you can find all details about your excitation calculation. Use the menu to jump to
the relevant part of output:

Select SCM → Output
Select Response Properties → All Singlet-Singlet Excitation Energies
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Closing the ADF-GUI modules

To close all modules for your excitations calculation at once, use the Close command from the SCM menu:

Select SCM → Close

Close will close all open modules that have your current job loaded, except ADFjobs. The Close All
command will close every ADF-GUI module, including ADFjobs:

Select SCM → Close All

All ADF-GUI modules (and BAND-GUI modules if any) should be closed.
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Tutorial 3: Vibrational frequencies of ethane

Step 1: Start ADFinput

For this tutorial we again prefer to work in the Tutorial directory:

cd $HOME
Start adfjobs
Click on the Tutorial folder icon
Start adfinput using the SCM menu

Step 2: Create your ethane molecule

Next we create an ethane molecule. This is almost identical to making ethanol:

Select the C-tool
Click once to make a carbon atom
Click again to make a second carbon atom
Select Edit → Add Hydrogen
And do it again: ... add hydrogen
Click the pre-optimize button
Click the Symmetrize button (the button with the star, on the bottom toolbar)

You need to add hydrogen twice: the first time one carbon atom was selected. Thus, the 'Add Hydrogen'
command added the hydrogen to that selected atom only. By repeating the 'Add Hydrogen' command the
hydrogens are added in all possible places.

Alternatively, you can, after placing the second atom, click on that atom to finish using the C-tool. In this
case none of the carbon atoms will be selected and you can easily add all the hydrogens at the same time.

The symmetrization should have enforced perfect D3d symmetry, using the Symmol program. The Symmol
program has been developed by Pilati and Forni, see the balloon help on that button for details..

Step 3: Optimize the geometry

Now optimize the geometry using ADF, as in the second tutorial:

Enter a title (like 'Ethane')
Select the 'Geometry Optimization' preset
Select File → Run
Save your input with a nice name ('ethane')
Wait for the calculation to finish (check the logfile)
In the dialog that appears, click Yes to import the optimized geometry
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Step 4: Calculate the vibrational frequencies of ethane

Now we will set up and run the frequencies calculation. It is important to start with the optimized structure, so
make sure you did import the optimized coordinates (the last step of the previous instructions).

Select the 'Frequencies' preset
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Select File → Run
Click 'OK' to save over the previous version
Click 'Yes' when ADFjobs warns that results are already present
Wait for the calculation to finish

Step 5: Results of your calculation

Logfile: ADFtail

When the calculation is finished the end of your logfile will look something like this:
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At the end ADF calculates the force constants for the vibrations.

IR-spectrum (vibrational spectrum): ADFspectra and ADFmovie

Select SCM → Spectra

The IR spectrum is shown. You can save a picture to use in other programs using the 'Save Postscript'
command from the 'File' menu. Alternatively, you may export the xy coordinates of the spectrum to a plain
text file for you own graphing application.

If you move the mouse pointer above the spectrum you will get more information about the peaks in pop-up
windows:

Move the mouse pointer above the largest peak and keep it there
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The list of normal modes contributing to the IR peak will show up. By clicking the mouse button at this point,
all these modes will be animated, each opened in a separate ADFmovie windows. Alternatively, pressing
and holding the mouse button down, a list of these modes with their symmetry labels will show up:

Press and hold down the mouse on the largest peak

Choosing one of the modes from the the pop-up list, you can visualize only the corresponding mode.

Select one of the modes in the pop-up menu
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ADFmovie should start and show the corresponding normal mode.
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Advanced ADF-GUI tutorials

Tutorial 4: Structure Building

First you will build an ethanol molecule again, but this time using structures. As another example, you will
build a small peptide chain.

Next, you will learn how to use the predefined metal complex structures.

Finally, you will set up your own structures library.

Step 1: Start ADFinput

For this tutorial we again prefer to work in the Tutorial directory:

cd $HOME
Start adfjobs
Click on the Tutorial folder icon
Start adfinput via SCM → ADFinput

Step 2: Building an ethanol molecule

In the first part of this tutorial you learned how to build an ethanol molecule. Here, we will do this again, but
this time using the structures building tool. To start, we first need to build a methane molecule:

Select the C-tool
Click somewhere in the drawing area to make a carbon atom
Select Atoms → Add Hydrogen , or faster: press the shortcut (Control-H or
Command-H)
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Now, we are ready to start using the structures.

Add a methyl group to the methane

Select the Structures tool → Alkyl Chains → Methyl structure
(the structures tool is the benzene-like logo)

Notice that the button of the structures menu is glowing, which means that the structure-tool is in use.

Double-click on one of the hydrogen atoms

87



You will see that the hydrogen is replaced by a methyl group.

Note that:

• The methyl is orientated along the newly formed C-C bond and the new hydrogens point
away from the existing ones.

• The double-clicked hydrogen is replaced by the carbon atom, since this atom is the 'replacing'
atom.
This atom is defined through having xyz-coordinates (0,0,0).

• The background glow moved from the 'Structures' tool to the 'Pointer' tool button; the 'Pointer' tool
is active again.

Add the hydroxyl group

Select the Structures tool → Ligands → OH structure
Double-click on one of the hydrogen atoms
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Again, the hydrogen is replaced by the structure. In this case, the oxygen replaces the double-clicked atom.
Notice that the hydrogen is precisely aligned along the C-O bond and points away from the rest of the
molecule. This shows you the very general way in which the structures will align according to the bonds in
the original molecule and those in the structure. In this case, the hydroxyl group is not immediately
orientated as it normally would be in an ethanol molecule:

Click the pre-optimize button

Add another 'solvent' ethanol

As you might have noticed, ADFinput comes with a number of predefined structures. One of these is the
'Solvent' structure Ethanol. Add this molecule in empty space:

Select the Structures tool → Solvents → Ethanol structure
Left-click in empty space near the hydroxyl group

Note that the oxygen is selected. Again, this oxygen is defined through having xyz-coordinates (0,0,0). Next
we select the new molecule and orient it with the mouse to a reasonable position:
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Use the Select → Select Molecule menu command
Use the mouse to rotate the ethanol molecule to your favorite orientation

This way you can easily add explicit solvent molecules.

Step 3: Building a peptide chain

As another example, we will build a small peptide chain.

Select File → New
Click 'No' as we do not want to save the setup
Select the Structures tool → Amino Acids → AA Backbone structure
Place it in the drawing area
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There appears a subunit (or actually two) of a basic peptide chain. Notice that one of the atoms is selected,
namely the terminal nitrogen. This atom is, again, the 'replacing' atom. In order to extend the peptide
backbone, you now have to choose the right atom to be replaced. The obvious choice is the (non double-
bonded) terminal oxygen.

Press the space bar, which activates the last used option
of the 'Structure' tool ('AA backbone' here).
Double click on the terminal oxygen.
You may want to use View → Reset View.
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You can now replace the hydrogens on the backbone by amino acid side groups of your choice. These can
be found in the Structures tool → Amino Acid → AA Side Groups submenu.

Step 4: Metal complexes and ligands

In the submenu 'Metal Complexes' you can find a set of predefined complexes corresponding to commonly
encountered geometries. Furthermore, there are a number of ligands to be found, which can be easily used
with these metal complexes.

Predefined Metal Complex Geometries

Select the File → New command
Click No (do not save changes)
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Select Structures tool → Metal Complexes → ML6 Octahedral tool and place it in the
drawing area

Notice that six dummy ("Xx") atoms have been placed around the metal center in an octahedral fashion.

Select one of the dummy atoms by clicking on it
Select Select → Select Atoms Of Same Type menu command

The Ligands structure submenu contains a number of ligands which can be used to replace the dummy
atoms. The Structure menu can, however, also be reached via the Atoms menu.

Select the Atoms → Replace By Structure → Ligands → CN command
Click in empty space to clear the selection
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Notice that all dummy atoms in the selection are replaced by CN ligands.

Bidentate Ligands

In order to use the bidentate ligands, we must start with a bare metal center.

Select the File → New command
Click No (do not save changes)

Place an iron atom in the drawing area
Select the Structures tool → Ligands → Bidentates → Ethylenediamine structure
Double-click on the metal atom
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You can see that, in this case, the metal atom is not replaced by an atom of the structure, contrary to
previous experience, but that the bidentate ligand is simply attached to the central metal atom. This works
because the 'replacing' atom in all bidentate structures is a dummy atom, which has the property that it won't
replace an existing atom. The metal atom will simply take over the bonds that existed on the dummy atom in
the structure. You can easily verify this when you would place the structure in empty space. Other
multidentate ligands are defined in a similar fashion.

Press spacebar and double-click again on the metal atom
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Notice that the second ligand appears opposite the existing one.

Modifying the Plane Angle

To change the relative orientation of two bidentate ligands, we can change the plane angle. The planes are
defined by two sets of three atoms, the central one being present in both sets. In this case this will, of
course, be the metal atom.

Select, in order, the two nitrogens on ligand one, the metal atom,
and the nitrogens on the second ligand.
Change the plane angle to 90 degrees
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In this way, you can easily change the environment around the metal from square planer to tetrahedral. This
feature works as long as you choose the atoms in right order, and if the defined planes can freely rotate
relative to each other.

Step 5: Your own structures library

You can make your own structure library very easily. First (before starting ADFinput) define an environment
variable 'SCM_STRUCTURES'. It should point to some directory in which to search for possible structures.
When you start ADFinput, the $SCM_STRUCTURES directory INCLUDING all subdirectories will be
searched for structures. A structure is stored in an .adf file, you can just use any .adf file that you have
created yourself.

You can define this environment variable in your shell startup scripts, or you can use the Environment panel
in the GUIprefs module.
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Defining your structures

To be able to actually use the structures as described earlier, it is necessary to define one of the atoms as
having xyz-coordinates (0,0,0). This will then be the atom that will actually appear at the spot of the atom
that is replaced by the structure.

Select the File → New command
Click No (do not save changes)

Place a 'Methyl' structure in the drawing area
Replace the hydrogen atoms by chloride atoms and pre-optimize
Select the central carbon atom
Choose Edit → Set Origin
Save the structure in (a subdirectory of) your $SCM_STRUCTURES directory

The new structure will in the structures menu and can be directly used.
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Using dummy atoms

Dummy ("Xx") atoms are treated a little different when used in structures. A dummy atom will not replace an
existing atom when it is defined as the 'replacing atom'. Instead, the double-clicked atom will remain and will
accept the bonds that the dummy atom had in the structure.

Build a methane molecule
Replace the carbon atom by a nitrogen atom
Select one of the hydrogens and replace it by a dummy atom (the Xx atom type)
Select the dummy atom and choose Edit → Set Origin
Save the structure in (a subdirectory of) your $SCM_STRUCTURES directory

Now you can select the structure from the structures menu and directly use it.

Select your new structure from the structures menu
Double-click on one of the hydrogens

Notice that the hydrogen atom is not removed and that the NH3 group is attached to it. Similar behavior has
been demonstrated with the bidentate ligands, where the dummy atoms are also used.
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Tutorial 5: HCN Isomerization Reaction

This tutorial consists of several steps to study the isomerization reaction of HCN:

• Geometry optimization
• Linear transit
• Quick frequency calculation
• Transition state search
• Accurate frequency calculation
• IRC

Step 1: Prepare the HCN molecule

cd $HOME
Start adfjobs
Click on the Tutorial folder icon
Start adfinput using the SCM menu
Draw an HCN molecule (first the N, next the C and finally an H atom)
Select the C-N bond and make it a triple-bond
Pre-optimize the geometry

You should get a linear molecule as shown in Fig 1.

Select the "Geometry Optimization" preset
Select the DZP basis set
Save the molecule with the name HCN_GO
Select File → Run

The geometry will be optimized, using a DZP basis set.

Click "Yes" when asked to read new coordinates from the HCN_GO.t21 file
Check the C-N and C-H distances

They should be about 115 and 108 pm (1.15 and 1.08 Angstrom), respectively.

Write down the value of the bonding energy printed
at the end of the calculation in the ADFtail window
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Step 2: Create a rough approximation for the transition state geometry

The HCN molecule has an CNH isomer. There is an energy barrier between these two states. We are going
to find the transition state and calculate its height. To find a better starting point for the transition state
search we will perform a linear transit calculation as a rough approximation of the reaction path. We will vary
the H-C-N angle in steps between 40 and 140 degrees and optimize bond lengths at each angle.

To set up the linear transit calculation:

Select the 'Linear Transit' preset from the 'Main Options' panel
Now select the 'Geometry Constraints and Scan' panel
Select all the atoms

You should see '+ N(1) C(2) H(3) (angle)' note in the right panel now:

Click the '+' sign to add the angle constraint

Now '- N(1) C(2) H(3)' and the two fields as limits for the degree parameter appear.

Enter '140' and '40' in the 'degrees' fields
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Before running the calculation, we need to do one more thing: reduce the symmetry. This is necessary
because intermediate geometries during the linear transit have lower symmetry than the starting C(lin):

Change the symmetry from AUTO to NOSYM in the 'Symmetry' panel

The set up is complete. Now we will run the LT calculation:

Save the file with as 'HCN_LT' (use the File → Save As command)
Run the calculation

Running might take a few minutes. When the run is finished:

Click "Yes" when asked to read new coordinates

You will see the last geometry, close to CNH. To see how geometry was changing during the LT run, use
ADFmovie:

Select the SCM → Movie command
Select all atoms (use shift-drag to make a rectangle around the atoms)
Use the View → Align Screen command to make sure you can see all atoms
Click somewhere in empty space to deselect the atoms
Select the Graph → Energy command
Use the View → Converged Geometries Only command

You will see the hydrogen atom moving from C to N. You will also see a graph of the energy as function of
the LT steps. As the movie is playing a dot shows the corresponding position in the graph.

Somewhere along the path, there is a transition state we are looking for. Note that you needed to use the
'Optimized Geometries Only' command to filter out all the intermediate geometry step, so that you get only
the converged geometries for each LT step.

In the graph, click (without moving!) on the top of the energy graph
Alternatively, use the arrow keys (cursor keys) to move between different stpes
Note which geometry has the maximum energy
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You should find that at about 60 degree angle the maximum energy is reached. This is Frame 6 (the 7th LT
step), see figure:

You can see it more clearly in the output file:

Select the SCM → Output menu command
In the ADFoutput window select the Other Properties → 'LT Path command

You will see that indeed the geometry number 7 (corresponding to Frame 6 in ADFmovie) has the highest
energy. In this particular example the choice of the angle is not very important, but in general you will always
want to choose the best approximation for the transition state available.

We will now prepare the search for the transition state starting from this geometry:

Make sure frame 6 is selected in ADFmovie
Use the File → Update Geometry In Input command

The geometry of HCN in your ADFinput window will be updated to match the geometry currently selected in
the ADFmovie window:
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Step 3: Finding the transition state: prepare approximate Hessian

It is important to have a good starting Hessian with one imaginary frequency when performing a TS search.
We are going to create such a Hessian by doing a quick frequencies calculation:

Select the "Frequencies" preset (from the 'Main' panel)
Set the integration accuracy to 4.0
Change the symmetry back to AUTO
Select the 'Geometry Constraints and Scan' panel
Remove the Angle Constraint: click on the '-' in front of the angle constraint
Save the molecule with as 'HCN_Freq1' (Save As)
Run the calculation

The frequency calculation is now in progress and will run very fast. When it has finished:

Select the SCM → Spectra command
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If everything was done correctly, you should see a spectrum with three peaks: two in the range of 2000 1/cm
and one peak in the range of negative or very low positive values. A negative frequency value actually
means that it is an imaginary frequency.

Click with your mouse on the peak corresponding to the imaginary frequency

The ADFmovie program will start displaying the normal mode corresponding to the frequency. Check that
the frequency indeed corresponds to the H atom moving parallel to the C-N bond.

Step 4: Search for the transition state

Now you have a result file, HCN_Freq1.t21, with an initial geometry for a transition state search. This file
also contains a Hessian matrix (produced with the frequencies calculation) that can be used to kick-start the
TS procedure.

Bring ADFinput with the HCN_Freq1 calculation to the foreground
Select the 'Transition State Search' preset
Select the 'Files (Restart)' panel
Click the file select button (looks like a folder) in front of the empty
'Restart file:' field
Select the HCN_Freq1.t21 file and click 'Open':
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Save the set up as HCN_TS (Save As)
Run the calculation

After the calculation has finished (again very fast), you will be asked to read the new geometry from the
results file HCN_TS.t21:

Answer "Yes" to import the latest geometry
Make a note of the bond energy for the transition state (visible in the
logfile)

ADFinput will now display the transition state geometry.

If you compare the bond energy with the bond energy of the optimized HCN molecule from the first
calculation, the difference should be about 1.9 eV. Also check that the geometry makes sense: the C-H and
C-N distances should be around 1.20 and 1.18 Angstrom and the H-C-N angle should be about 70 degrees.

Step 5: Calculating frequencies at the transition state

After every transition state search it is wise to verify that you indeed have one and only one imaginary
frequency. For this we will repeat the frequency calculation at the TS geometry:

Make sure you have HCN_TS open in ADFinput
Select the "Frequencies" preset (from the 'Main' panel)
Save with name HCN_Freq2
Run

The calculation is running, should not take much time. After the calculation has finished:
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Select the SCM → Spectra command

You will be presented with an IR spectrum of the molecule featuring three bands roughly located at 2550,
2050, and (imaginary) -1040 1/cm.

Click on the band at -1040

You should get a movie showing the normal mode corresponding to this frequency, telling us that this is
indeed the reaction coordinate we are studying.

Step 6: Following the reaction coordinate

ADF can follow the minimum-energy path from the transition state to one or the other product. The method
used in ADF for this is called Intrinsic Reaction Coordinate (IRC). This tutorial step is optional because it
might take some time to complete.

Bring HCN_Freq2 in ADFinput to the front
Select the "IRC" preset
Go to the 'Task: IRC panel'

The 'Task: IRC' panel, on the right-hand side, allows you to specify various parameters for the IRC method.
The most important parameter is the direction to follow. The choice is more or less arbitrary. By choosing
"Forward path" or "Backward path" will lead you to one or the other product but it's hard to tell which of the
two in what case. We will calculate both paths at once, thus we do not need to change the default.

Type 'HCN_IRC' in the 'Title:' field of the 'Main Options' panel
Save as HCN_IRC
Run

After some minutes the calculation will finish. You can use ADFmovie to view the IRC path. Of course you
need again to make sure to show the converged geometries only:

Select the SCM → Movie command
Select the View → Converged Geometries Only command

From this movie you can see the IRC path, and the energies at the most interesting points. As we have
calculated the forward and backward path in one run, in the movie you will first see the IRC in one direction
(forward), and next resuming in the other direction (backward).

You can also examine some properties along the IRC path by studying the output file:
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Select SCM → Output
Use the Other Properties → IRC Path menu command

You will see a table with the properties along the forward path. To get the backwards path:

Click on the blue header 'Dist from TS ...'

The output browser should jump to the next section with that header, which is the table for the backward IRC
path.

Tutorial 6: TlH (thallium hydride) Spin-Orbit Coupling

This tutorial consists of several steps:

• TlH spin-orbit fragment analysis
• Separate calculations for Tl and H
• Visualization of the energy diagram
• Visualization of spinors
• Calculate the atomization energy

Step 1: Prepare molecule

First create a TlH (thallium hydride) molecule with a bond length of 1.87 Angstrom (the experimental bond
length):

Open ADFinput and draw a TlH molecule.
Select the Tl and H atoms
Set the distance between the atoms 1.87 Angstrom

(use the distance input field below the molecule)
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Step 2: Set calculation options

Next we will set up the calculation. The following details need to be set:

Set the title to 'TlH spin-orbit coupled'
Select 'GGA:BP' from the 'xc potential in SCF' menu
Select 'Spin-Orbit' from 'Level of relativistic theory' menu
Select the basis set 'TZ2P' from the 'Basis Set' Menu
Select the core type 'None' from the 'Core Type' menu

The 'Main Options' Menu will now look like:
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We are going to perform a fragment analysis. This will allow us to compare the scalar relativistic results with
the spin-orbit results very easily. To do this we will define the whole molecule as one fragment. Just follow
the steps, in another tutorial many more details about fragment calculations will be explained.

Select both atoms
Select the 'Regions' panel
Click the '+' button
Change the name of the new region (Region 1) to TlH_SR
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You have now defined a region containing all atoms, with name TlH_SR.

Select the 'Fragments' panel
Click the 'Use fragments' check box

Step 3: Run your calculation

Use the File → Save menu command
Enter the name 'TlH_SO' in the 'File name' field
Click 'Save'

Now you have saved your current options and molecule information. Since we have set up a fragment
calculation, also the .adf and .run files for the fragment have been saved. Just to be sure what the fragment
will look like, lets check it in ADFinput:

Make sure the 'Fragments' panel is still the current panel
Click on the 'Open' button (the dot) for the TlH_SR fragment
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A new ADFinput window will also appear with the name 'TlH_SO.TlH_SR.adf. This is the name of the
fragment. You can verify that the fragment has the 'Scalar' relativistic option selected, which is required if the
results will be used as a fragment. You could also make changes here, but in this example no changes are
required. We will use the fragment as it has been generated by ADFinput automatically, so close this
ADFinput window:

Select the ADFinput window with the name 'TlH_SO.TlH_SR.adf.
Select File → Quit

Now we want to actually perform the calculation, both for the fragment and the whole molecule.

Select the ADFinput window with the name 'TlH_SO.adf.
Select File → Run

Now two calculations will run: first the building fragment (the scalar version), and next the version including
spin-orbit coupling. You will see the two logfiles. Wait until both calculations have finished:

Wait until ADFtail shows 'Job ... has finished' as last line
Select File → Quit
Repeat for the second ADFtail, thus closing both logfiles

Step 4: Results of the calculation

TlH energy diagram

Select the ADFinput window with the name 'TlH_SO.adf.
Select SCM → ADFlevels
Select View → Labels → Show
Press and hold the Right mouse button on the stack name 'TlH_SO',

Click on 'Zoom HOMO-9 .. LUMO+9'.
Next try to zoom using a drag with the right mouse button, or using the scroll
wheel.
Do this such that only levels between -0.1 and -0.7 eV are shown.
You can move the levels vertically by dragging with the left mouse button.
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This Figure shows that the first-order spin-orbit coupling is important to split energy levels. Especially for the
Tl core levels the spin-orbit coupling is more important than the ligand field splitting. Compare the 8pi,
13sigma, 4delta orbitals (close to 5d atomic Tl orbitals) with the 11j3/2, 20j1/2 spinors (close to 5d3/2 atomic
Tl spinors) and 5j5/2, 12j3/2, and 21j1/2 spinors (close to 5d5/2 atomic Tl spinors).

If you Press and hold the Right mouse button on one of the levels, you can select a spinor, that spinor will
be shown using ADFview, see also the next paragraph. You can also show all spinors (in the case of a
degenerate level) at once.

The energy diagram of the scalar relativistic fragment calculation shows the atomic contributions to the
scalar relativistic levels.

Bring ADFjobs to the front
Select the TlH_SO.TlH_SR job (the scalar relativistic fragment)
Use the SCM → ADFlevels command
Select View → Labels → Show
Press and hold the Right mouse button on the stack name 'TlH_SO.TlH_SR',
Click on 'Zoom HOMO-4 .. LUMO+4'.
Next zoom and move the levels using a right mouse drag and or scroll wheel.
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Visualization of spinors

Visualization of spinors is more difficult than visualization of orbitals. A spinor Ψ is a two-component
complex wave function, which can be described with four real functions φ: real part α φαR, imaginary part α
φαI, real part β φβR, imaginary part β φβI:

Ψ = (
φαR + i φαI

φβR + i φβI)

The density ρ is:

ρ = Ψ† Ψ

The spin magnetization density m is:

m = Ψ†σ Ψ

where σ is the vector of the Pauli spin matrices. A spinor is fully determined by the spin magnetization
density and a phase factor eiθ, which both are functions of spatial coordinates. In ADF one can visualize the
(square root of the) density and spin magnetization density, however, the phase factor eiθ is summarized
only with a plus or minus sign. For this small molecule a fine grid is chosen for better visualization.

Select the ADFinput window with the name 'TlH_SO.adf.
Select SCM → View
Rotate the molecule, such that one can see both atoms.
Select Fields → Grid → Fine
Select Add → Spinor: spin magnetization density
In the new control line, press on the pull-down menu and
Select Orbitals (occupied) → 3 → SCF_J1/2:1  22:  1.0  ....
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The arrows in this picture are in the direction of the spin magnetization density m. All arrows are
approximately in the same direction, which means that this spinor is an eigenfunction of spin in this direction
of the arrows. In fact this 22 j1/2 spinor is almost a pure α orbital. The arrows are drawn staring from points
in space where the square root of square root of the density is 0.03. The color of the arrows are default red
or blue, indicating minus or plus for the phase factor eiθ.

The (square root of the) density and the approximate phase vector eiθ can also be viewed separately:

Select Add → 'Isosurface: Double (+/-)
In the new control line, press on the pull-down menu and
Select Orbitals (occupied) → 3 → 'SCF_J1/2:1  18:  1.0  ..
Deselect View → Molecule Ball & Sticks → Sticks
In the control line with 'Spinor' uncheck the check box at the left end of
this line
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This spinor 18j1/2 is almost a pure 5p1/2 Tl spinor. A p1/2 atomic orbital has a spherical atomic density, but
a spin magnetization density which is not the same in each point in space.

In the control line with 'Spinor', press on the pull-down menu and
Select Orbitals (occupied) → 3 → SCF_J1/2:1  18:  1.0  ...

Show the 'Spinor' (check the left checkbox for the spinor line)
Hide the 'Double Isosurface' (uncheck the left check box for the double iso
line)
Hide the atoms: View → Molecule Ball&Sticks → Sticks
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Step 5: Calculate the atomization energy including spin-orbit coupling

The calculation of the atomization energy is not a simple problem in DFT. Spin-orbit coupling is an extra
complication. In this paragraph a way is presented how to calculate the atomization energy using spin-
polarized calculations in the non-collinear approximation.

If you wish, you can skip the rest of this tutorial.

The Tl atom

To calculate an atomization energy we need to calculate the atoms also including spin-orbit coupling. The
easiest way is to start with the TlH_SO.adf file and change this to an atomic file.

Since the Tl atom is an open shell atom for an (accurate) atomization energy we need to do an unrestricted
calculation. The best theoretical method is the non-collinear method. Note that the 'Spin polarization' field is
not used in the non-collinear method.

Select the ADFinput window with the name 'TlH_SO.adf.
Delete the H atom (select it and press the backspace key).
Select the 'Fragments' poanel
Uncheck the 'Use fragments' option
Select the 'Regions' panel
Remove the TlH_SR region (click on the - button in front of it)
Select 'Main Options' panel
Select the preset 'Single Point' in the 'Preset' menu.
Enter the name 'Tl spin-orbit coupled' in the 'Title' Menu'.
Check the 'Unrestricted:' box.
Select the Relativity panel, and then select 'Spin-Orbit' in the 'Relativity:'
field there.
Select 'NonCollinear' from the 'Unrestricted Options' Menu.
Select File → Save As
Enter the name 'Tl_SO' in the 'File Name' field.
Click on 'Save'.
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Now we want to actually perform the calculation for the Tl atom

Run the calculation.
Wait until ADFtail shows 'Job ... has finished' as last line
In the window showing the logfile (the ADFtail window Tl_SO.logfile):
Select File → Quit

The H atom

Basically we can follow the same steps as for the Tl atom, but in this case we will start with Tl_SO.adf file
and change this.

Select the ADFinput window with the name 'Tl_SO.adf.
Select the 'Main Options' panel.
Enter the name 'H spin-orbit coupled' in the 'Title' Menu'.
Select the Tl atom
Use the Atoms → Change Atom Type → H.
Select File → Save As...
Enter the name 'H_SO' in the 'File Name' field.
Click on 'Save'.
Select File → Run
Wait until ADFtail shows 'Job ... has finished' as last line
In the window showing the logfile (the ADFtail window H_SO.logfile):
Select File → Quit

TlH atomization energy

The atomization energy including spin-orbit coupling is a combination of several terms.

Select the ADFinput window with the name 'TlH_SO.adf.
Select SCM → Logfile
Write down the value of the bonding energy printed at the end of the
calculation in the

ADFtail window.  (should be around -1038.60 eV)
Select File → Open
Select the file 'TlH_SO.TlH_SR.logfile'
Write down the value of the bonding energy printed at the end of the
calculation in the

ADFtail window.  (should be around -3.83 eV)
Select File → Open
Select the file 'Tl_SO.logfile'
Write down the value of the bonding energy printed at the end of the
calculation in the

ADFtail window.  (should be around -1039.32 eV)
Select File → Open
Select the file 'H_SO.logfile'
Write down the value of the bonding energy printed at the end of the
calculation in the

ADFtail window.  (should be around -0.95 eV)

The atomization energy including spin-orbit coupling is in this case, the bond energy printed in the
TlH_SO.logfile plus the the bond energy printed in the TlH_SO.TlH_SR.logfile minus the bond energy
printed in the Tl_SO.logfile minus the the bond energy printed in the H_SO.logfile. (approximately -1038.60 -
3.83 + 1039.32 + 0.95 = -2.16 eV, experimental number is close to -2.06 eV.)
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Tutorial 7: Multi-Level principles: Regions, Quild and QMMM

In this tutorial the basic concepts of setting up multi-level calculations in the ADF-GUI will be demonstrated.
In most cases one would use a multi-level method for big systems: handle the full system with a fast
method, and use ADF to study a particular region of interest with more detail. As big systems will take too
much time for a tutorial, the concepts will be shown with very small toy systems that are not typical
applications.

Step 1: Regions

For all multi-level calculations you will need to define regions.

Within ADFinput, a region is a collection of atoms. You manage your regions with the 'Regions' panel in
ADFinput. It allows you to define new regions, modify existing regions, and to apply some commands on
particular regions.

As a first example, we will work with an aceton molecule (CH3COCH3) to demonstrate how to use Quild.

Generate regions

Start ADFinput, and build an Aceton molecule
Select one of the methyl groups
Select the 'Regions' panel
Click on the '+' button to add a new region
Change the name 'Region_1' into 'Methyl' (the name is editable)

You have just defined a new region, with a name 'Methyl'. In your molecule window you can see what atoms
are part of this region: they are enclosed in slightly ghost-like spheres. Note that there are now two regions
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define: the region that you defined, and a region called 'All' that is always present. Obviously, the All region
includes all atoms.

Now we will define yet another region: the rest of the molecule. One way to do this is just to select the atoms
that should be part of it, and pressing the '+' button as you did before. However, to demonstrate some of the
things you can do with regions we will do it in another way:

Click the check button in the 'All' region
Click the '+' button to create a new region, as you did before
Click the check button in the 'Methyl' region
Click the '-' button in the 'Region_2' line, on the right-hand side

Basically, what you just did: select all atoms, make a new region containing all atoms, select the atoms in
the Methyl region, remove the selected atoms from the new region. By clicking on the select buttons in the
regions you can easily verify that your regions are now as they should be.

Visualization options per region

You can easily change what regions, and atoms within that region look like:

Click in the check box in front of the 'Methyl' region name to uncheck it

You should observe that the ghost-like region visualization disappears. Please turn it back on:

Click in the check box in front of the 'Methyl' region name to check it
Click on the right arrow at the end of the 'Region_2' line,

and use the 'Sticks' command from the menu that appears
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Now anything in 'Region_2' will be visualized as sticks only. Obviously you could also select any of the other
display options.

Step 2: Quild

Once you have defined your regions, it is easy to set up the Quild calculation:

Select the Quild panel
Click the '+' button to add an action
Click the '+' button to add a second action
In the first action, select DFTB in the 'Use' field
In the second action, select ADF in the 'Use' field
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The first action ('Total') defines what to do with the full molecule. It normally will apply to the whole molecule,
and thus the 'All' region is preselected. In the 'Use' field you have specified how to treat the whole molecule:
with DFTB.

The second action ('Replace') tells quild to replace the DFTB result for the selected region with results from
another method. The region for which we want to do this is the 'Methyl' region, and it happens to be
automatically selected. You can use the region pull-down menu will to select another region, and it offers
you a short-cut to make a new region.

In the 'Use' field of the second action you have selected what to use as a replacement method: ADF.

In the 'Remove' field it should be specified that you wish to remove the DFTB results for this region, but
ADFinput will enter this automatically when you save your job. You can also set it manually if you wish.

The Quild panel offers you to set some details for the quild calculation. Normally the defaults should work
fine.

Save your set up

Below the Quild panel you will now find three tabs: 'Quild', 'DFTB 1', 'ADF 1' and 'DFTB 2'. These tabs allow
you to set up the different parts of the calculation. Right now you could make adjustments of the global Quild
settings. If you press on the 'ADF 1' tab, you will have the option to set the details of the ADF calculation (for
the 'Methyl' region). And if you click on the 'DFTB 1' tab you can set up details of the DFTB part of the
calculation. The 'DFTB 2' tab is the DFTB calculation on the 'Methyl' group that will be removed from the full
system. Normally the set up for this calculation is identical to the full system (DFTB 1), but in some special
cases you will need to modify it. See the Quild manual for details.

Click on the 'ADF 1' tab
Look through the different panels, to see what options ADF will use. Do NOT
make changes!
Click on the 'DFTB 1' tab
Click on the 'DFTB 2' tab
Click on the 'Quild' tab

Now let's run this calculation:
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Run the calculation

When your calculation is finished you can view the resulting optimization using ADFmove:

Use the SCM → Movie command
Add a graph: Graph → Energy
Add a second graph: Graph → Add Graph

Show the energy of the ADF-subsystem on the second graph:
Graph → Quild Energies → job 2 : ADF ...

You can also open the output file using the SCM → Output command. The other visualization tools can not
be applied to the full Quild results, but they can be used to examine the result of the ADF calculation (on the
Methyl region). This is done in quildjob.2:

Show the ADFjobs window
Show the Quild job details (click on the triangle to show the details)
Show the Local files (click on the triangle to show them)
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Double-click on the .results/quldjob.2.t21 file
Visualize the HOMO in ADFview
Click on the Isosurce:Double pulldown menu and use the Show Details command
Change the Opacity to 70

Note that Quild has added a dummy hydrogen to cap the broken bond.

In the ADFview window, use the SCM → ADF Levels command
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Now you have the ADF result file for the methyl group visible in ADFview and ADFlevels. With ADFview and
ADFlevels you can examine the ADF results as usual.

Step 3: QMMM

Generate ethanol in water

To demonstrate how to set up a Quild calculation using ADFinput, we will use ethanol in water as an
example. This will also show you how to add explicit solvent molecules to your system:

Build an ethanol molecule
Pre-optimize the structure
Select the 'Solvation' panel
Click on 'Explicit Solvent Molecules'
Change the radius of the solvent sphere to a small value,

such that 10 solvent molecules will be generated
Click on 'Add Solvent'
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As you can see, ADFinput has generated 10 water molecules around your ethanol molecule. It also has
created two regions: a Solute region containing the ethanol molecule, and a Solvent region containing the
water molecules. The visualization option for the Solvent region is such that the water molecules will only be
shown using a Wireframe representation.

Set up the QM/MM calculation

The next step is to set up the QM/MM calculation:

Select the 'QMMM' panel
Select the 'Solute' region in the 'QM Region' pull-down menu
Change the QMMM Task to GeometryOptimization

126



Now you will have three tabs: the main QMMM tab that allows you to set QMMM details, the 'ADF 1' tab that
is the setup for the ADF calculation for the Solute subsystem, and the 'MM 3' tab that sets up the MM
calculation for the full system.

ADFinput is currently not very smart in setting the proper atom types for a MM calculation. So you will need
to examine the atom types as they are generated in the MM input, and fix them if they are not correct. To fix
this, if needed, use the Atom Inspector panel to set the Tripos (or Amber) atom types as needed.

Click on the 'MM 3' tab
Check the atom types
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Run the QMMM calculation, and see results

Run your calculation File → Run
Show the optimization movie: SCM → Movie
Graph → Energy

Note that ADFmovie (and the other GUI modules) will only show the results for the QM part of your
calculation.

To get detailed information on your QMMM calculation, you can check the output file using the SCM →
Output command.

Tutorial 8: ADF Fragment Analysis

This tutorial will show you how to use the Fragment Analysis within ADF. The two examples used here are:

• Ni(CO)4
• PtCl4H22-

The tutorial will walk you through two different fragment analysis examples. You will set up the calculation,
run it, and visualize the result. The resulting ADFinput input file (*.adf) is available in the examples directory
included in the ADF distribution. In the examples documentation you can read how to set up a similar
calculation without ADFinput.

The first example in this tutorial is Ni(CO)4. It consists of one Ni fragment and once CO fragment that is
repeated four times.

The second example is PtCl4H22-. It consists of a PtCl42- fragment, and one H2 fragment. It is a good
example on how to specify the charges of the fragments.
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Step 1: Build Ni(CO)4

The structure is perfectly tetrahedral. You should be able to build the molecule yourself, using the
techniques described in earlier tutorials. One possible way:

Start ADFinput
Build a tetrahedral metal complex using the Structures button

(Metal Complexes>ML4 tetrahedral)
Change the central atom into a Ni atom
Select one ligand
Use the Select → Select Atoms Of Same Type menu command
Change them in CO ligands: Atoms → Replace By Structure → Ligands → CO
Choose the 'Geometry Optimization' Preset
Save and Run
When the run has finished, click 'Yes' to import the optimized coordinates
Save

Your molecule should look something like this:
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Step 2: Define fragments

The fragments that ADF uses are based on the regions that you define. In this example we will generate five
new regions: one for the Ni atom, and one for each of the CO ligands. The regions for the CO ligands will
get special names to make sure that ADF recognizes them as one fragment repeated four times.

Repeated fragments are indicated with the fragment name followed by '/n', with n the number of the copy. All
copies must match such that one fragment can be positioned exactly over another fragment by rotation and
translation. ADF checks for this, currently ADFinput does not. In this particular example all four CO
fragments are obviously identical by symmetry.

Select the 'Regions' panel
Select all atoms
Click the '+' button to add another new region (containing all atoms)
Select the Ni atom
Click the '-' button on the right side of the 'Region_2' line

to remove the Ni atom from that region
Change the name of 'Region_2' into 'CO'

Now two new regions are defined: one for the Ni atom, and one for the ligands. The next step is to split the
ligand region into four repeated regions:

Press the triangle on the right side of the CO region line
In the pop-up menu, use the 'Split By Molecule' command

This should result in the following regions:

Step 3: set up the fragment analysis run

The next step is very easy: we will tell ADF to perform a Single Point calculation (fragment analysis in ADF
only works with a single point calculation), and we tell ADFinput to use the regions that we just defined as
fragments:
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Open the 'Main Options' panel
Select the 'Single Point' preset
Open the 'Fragments' panel
Check the 'Use fragments' check box

In the Fragments panel you will see that one fragment is present, without charge: the repeated CO fragment.
ADF will use basic atomic atoms for any atoms not put in another fragment. Thus, the Ni atom will be an
atomic fragment.

Step 3: Run the fragment analysis and view the results

Next you will Save and Run the calculation. When you do this, ADFinput will actually save two different
calculations:

• The CO calculation (with matching .adf and .run file)
• The Ni(CO)4 fragment analysis calculation (with matching .adf and .run file)

You do not need to set up a separate ADF calculation for the CO fragment: when you run the fragment
analysis calculation, the run script will detect that the individual fragments first need to be calculated. It does
so automatically. Next, the fragment analysis calculation will run.

Save
Run
Observe the running of the fragment (CO), and the final fragment analysis

The CO-fragment and Ni(CO)4 calculations all have been performed.

This calculation results in the normal .t21 and .out output files. You can view them with the SCM → View
and SCM → Output commands. More interesting in the case of a fragment analysis is the interaction
diagram that you can view using ADFlevels:

Use the SCM → ADF Levels command
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In the center you see the levels of the whole molecule, on the sides you see the CO fragment and the Ni-
atom fragment. The interaction lines tell you which molecular orbitals come from which fragment orbitals.

In the output file you can find detailed information about the composition of the molecular levels in terms of
the fragment orbitals.

Step 4: Build PtCl4H22-

The following is a picture of the whole molecule. The colors of the Cl-atoms have been changed for clarity:

132



To make this molecule, an easy way is to start with an octahedral complex to ensure symmetry. Next make
changes to get this molecule, ending with a geometry optimization with ADF:

Build an octahedral metal complex using the Structures button
(Metal Complexes>ML6 octahedral)

Change the central atom into a Pt atom
Change four dummies in a plane into Cl atoms
Remove one of the remaining dummies
Change the remaining dummy in OH

(this will ensure the final two H's do not break symmetry)
Change the O atom into an H atom

Choose the 'Geometry Optimization' Preset
Set the total charge to -2
Select the Scalar ZORA relativistic option

Run

When the run has finished, click 'Yes' to import the optimized coordinates
Save
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Step 5: Define fragments

Define the PtCl42- and H2 fragments in the Regions panel:

Select the 'Regions' panel
Select the Pt and Cl atoms
Use the '+' button to add a new region, and name it 'PtCl4'
Select the two H atoms
Use the '+' button to add a new region, and name it 'H2'

Now the fragments are defined. Next, we set up the fragment analysis calculation:

Select 'Main Options' panel
Select the 'Single Point' preset
Open the 'Fragments' panel
Check the 'Use fragments' check box
Change the charge of the PtCl4 fragment to -2

Save

The other changes (the overall molecule charge, and the scalar ZORA option) have already been set
previously. The Single Point preset does not change these.
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When you click on the Open button (the big dot) next to the PtCl4 fragment, you can inspect the PtCl4
fragment setup:

Click on the Open button (the big dot next to the PtCl4 fragment)
in the 'Task: FragmentAnalysis' panel

Check the charge of the fragment in the newly opened ADFinput (should be -2)
Close the PtCl4 fragment ADFinput window

For more complex calculations, you could make additional changes to your fragment runs. However,
normally the set up as created by ADFinput should be fine.

Step 6: Run the fragment analysis and view the results

Next you will Run the calculation:

Run

After the calculation has finished, you can view the resulting interaction diagram:

Use the SCM → ADF Levels command

Use the mouse (drag with left mouse, scroll wheel, drag with right mouse)
zoom in on the interesting region (roughly from -0.5 to 0.4)

Select the PtCl4H2 column (by clicking on the name at the bottom
Use the View → Interactions → Show menu command

With the pop-up menu in the H2 column, shift the H2 levels by +0.28

Only interactions between visible levels are shown. So, if you zoom out no interactions will be visible for
some of the levels. That is the reason that you will need to use the Show Interactions menu command.

We needed to shift the H2 levels to accommodate that in the final molecule the fragment experiences the -2
charge, but this is absent from the H2 fragment calculation. The interaction diagram should look something
like the following:
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In the output file you can find detailed information about the composition of the molecular levels in terms of
the fragment orbitals.

Tutorial 9: Basis Set Effects for NH3 (ammonia) Geometry

This tutorial will help you to:

• pre-optimize structures using different methods, including MOPAC
• starting from an existing .adf file, create a batch of similar jobs using the Prepare tool in ADFjobs
• interactively submit a set of jobs using ADFjobs
• using the Report tool in ADFjobs, analyze results of multiple calculations at once

Step 1: Create and pre-optimize your molecule

Start ADFinput
Create an N atom
Press Esc, and click in empty space so that nothing is selected.
Create an H atom, not too far away
Press Esc, and click in empty space so that nothing is selected.
Add 2 more hydrogen atoms this way.

You should see one nitrogen and three hydrogen atoms in the drawing area now. We intentionally did not
add bonds between the N and H atoms!

First we will try to optimize this structure using the default pre-optimizer (SimpleMM):

Click 'Pre-Optimize' gear wheel button
Zoom out to see your atoms ...
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Using the default pre-optimization algorithm the non-bonded atoms will 'fly away' from each other:

The default pre-optimization will finally stop with 'SimpleMM optimization ready' message. Apparently the
result obtained is far away from the well-known anticipated NH3 molecule.

Next we will try to optimize using Mopac. If you do not have Mopac installed, please do exactly the same but
use DFTB instead of Mopac.

Undo the previous optimization: Edit → Undo
Select the 'Mopac' panel
Click the 'Run' button in the Mopac panel

The message 'MOPAC optimization ready' will be displayed in the ADFinput window:
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Mopac will produce a good-looking pyramidal ammonia molecule, with the N-H bond length of about 1.0
Angstrom.

Additionally, it will create proper N-H covalent bonding! These bonds are based on the bond-orders as
calculated by Mopac.

Step 2: Set up a single ADF calculation

Now with our pre-optimized NH3 molecule, we will set up a series of calculation: the optimization of NH3 with
ADF, using different basis sets. The first step is to set up a simple geometry optimization:

Select the 'Main Options' panel
Select the 'Geometry Optimization' preset
Save as NH3

We have used all defaults for basis set and so on.

Step 3: Set up a batch of ADF jobs

Next we will set up a series of calculations, using the Prepare tool.

Select the ADFjobs window
In ADFjobs window, locate the 'NH3' job saved earlier
Click onto 'NH3' line to select it
Use the Tools → Prepare... command
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The Prepare dialog window will pop up. Because we have selected the NH3 job earlier, NH3.adf file name
(including the path) will show up in the 'Run' field (otherwise, we can select NH3 using '+' button of the 'Run'
field).

Go to the 'Use these input options' and click '+'
Choose 'Basis Set and Frozen Core' → 'SZ' → 'Large'
In the similar manner, add basis sets 'DZ', 'DZP', 'TZP',

.. (optionally 'TZ2P' and 'QZ4P')
Use core 'Large' for all the basis sets
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The basis set options selected will show up in the 'Use these input options' field. Note that by default the
jobs will be created in the 'autojobs' directory, as specified in the 'Produce jobs' section.

Now click 'OK' in the Prepare window

The Prepare dialog will close and ADFjobs will open the 'autojobs' directory. Using NH3.adf, the Prepare tool
created a set of jobs inside 'autojobs' named as 'NH3.SZ.Large.adf', 'NH3.DZ.Large.adf' etc. The files
naming intuitively follows the basis set options which has been used, and the rest of the options of the newly
created files are exactly the same as in NH3.adf. The original NH3.adf file has not been altered.

Step 4: Run your set of ADF jobs

Now we are going to run the batch of ADF jobs which has been automatically prepared in the previous Step
3 of the tutorial Using ADFjobs, one can either run this set of jobs one by one, or all at once.

Click on the first job
Shift-Click on the last job
Run the jobs Job → Run

This will run the jobs in the default queue. Normally this is the Sequential queue, and the jobs will actually
run one after another.

The jobs will start running, and the corresponding ADFtail windows will pop up. Each ammonia optimization
job should not take more than a few minutes.

Step 5: Analyze results of several calculations at once

When all the ammonia optimization jobs are finished, we can compare the results. The main conclusion that
you will reach is that DZ (double zeta) basis set optimization, job name 'NH3.DZ.Large', leads to the
incorrect planar ammonia molecule. As covered in the preceding tutorials, you can optionally use several
GUI modules to observe that:

- ADFmovie, which will show the geometry optimization

- ADFinput, which will open the (last) converged geometry

- ADFview, which will open the converged geometry and also would display various density maps in 3D

For example, let us use ADFview to demonstrate the results:

Select job NH3.DZ.Large in the ADFjobs window (should then be highlighted)
Select SCM → View
Select Fields → Grid → Fine
Select Add → HOMO
In the isosurface contour value field which appeared at the bottom,

change the default '0.03' to '0.3'
Type 'Ctrl-minus' several times, until the central N atom ball

does not overlap strongly with the HOMO orbital.

Repeat for the other jobs

What you will observe is that HOMO of ammonia does not have the anticipated sp3 hybridization, when DZ
basis set is used (first planar ammonia as optimized in DZ, next pyramidal ammonia as optimized in DZP) :
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An automated procedure to report results from a list of ADF jobs is available. This task is achieved via using
the Report tool within ADFjobs. Below we will demonstrate how to do this for our set of completed NH3
molecule optimizations.

Go to the ADFjobs window
Select Tools → New Report Template...

This will open up Report dialog. In the 'Report' field, you can choose the name for your report file and its
format ('HTML' or 'Tab separated plain text'). The other fields ('General', 'Images', 'Results') contain various
relevant options you can choose for preparing your report.

In the 'Report'/'Template name' field, type 'MyReport'
In the 'Results' section check 'Dipole Moment' and 'Dipole Vector'
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Click 'OK'

The Report dialog will close, saving our template named 'MyReport'. Now we will generate actual report
following the saved template:

In ADFjobs window, select all the finished jobs from the NH3 set
Select Tools → Build MyReport Report

'Save As' dialog window will pop up, showing the 'report.html' default file name.

Choose your file name and location, then click 'Save'
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Now ADF will scan through your job list and prepare the report. Finally the browser will start showing your
report file (by default, named 'report.html'):

The Report tool created a table-like report of the results. Click on the image to see it in detail.

We can clearly see that only for DZ basis optimization our NH3 molecule is planar, see the last 'row' of the
report table. Above, we have selected to report dipole moment and dipole vector; these values show up in
the two last columns. Obviously the dipole moment is zero only for the planar NH3 structure.

Congratulations, we are done with the ammonia optimization tutorial!

If you want to exit all the GUI modules at once: select SCM → Close All

Tutorial 10: DFTB charges, Bader analysis, NBOs, and
Occupations

Step 1: DFTB: Pre-optimize and Charges

Start ADFinput
Make benzene
Select the DFTB panel
Press 'Run' in the DFTB panel to optimize benzene
Use the View → Atom Info → DFTB Charges menu command to show the DFTB charges
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Step 2: Bader analysis and NBOs

Next we set up the calculation to show the required properties and run it:

Set up a Single Point calculation with no frozen cores
Select the 'Other: Etot, Bader, Charge Transport' panel
Request Bader Atomic Properties
Request Save Bader atomic basins
Select the 'Localized Orbitals, NBO' panel
Request an NBO analysis
Request Boys-Foster localized orbitals
Run this setup

When the calculation is done (it should run very fast), we use ADFview to examine the Bader charges and
compare them with Mulliken charges:

Open the results with ADFview
Show the Bader atomic charges (View → Atom Info → Bader Charge)
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Color the atoms by Bader charges (View → Color Atoms By → Bader Charge)
Show the Mulliken charges (View → Atom Info → Mulliken Charge)

Next we inspect the NBOs and Boys-Foster localized orbitals. To remove the charge display we close and
open ADFview, but you could also have used the View menu to remove them by hand:

Close ADFview
Open the results again with ADFview
Add a Double Isosurface
Use the field menu in the new control bar, and

observe the labels present with the NBOs and NLMOs
Open NBO number 15 (should be similar to C6-H12)
Improve the grid by using Fields → Grid → Fine
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Obviously, you can also visualize the NLMOs or the Boys-Foster localized orbitals (which are just called
Localized Orbitals in the fields menu.

Next we inspect the Bader atomic basins. The numerical integration points are used for this purpose. The
color indicates to which atomic basin the numerical integration point belongs to.

Close ADFview
Open the results again with ADFview
Add → Bader Sampling
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One can also select one or more atoms, to see only the Bader atomic basins of the selected atoms.

Step 3: Occupations

Now we will remove one electron from a selected orbital (by symmetry) using ADFinput again.

Open your benzene calculation in ADFinput
Open the spin and occupation panel
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In the Spin and Occupation panel you see which orbitals are available (by symmetry, and spin if the current
set up is unrestricted). The numbers are the occupations. Next to the ADFinput window ADFlevels will also
have opened, and is showing a level diagram of your current molecule. This helps you to select the proper
occupation.

The level diagram is based on the existing result file (.t21) found. If none, ADFinput will suggest to do a
guess-calculation: a hopefully fast calculation using an inaccurate integration grid, and stopping after a few
SCF cycles. The level diagram shown in that case will not be accurate obviously but will still be helpful in
selecting the proper occupation.

Now, just as an example, we make a hole in the 3E2.g orbital. Note that this is NOT the HOMO.

Change the 4.0 to 3.0 in the 3 E2.g column (the third row)
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Close the guess adflevels
Close the ADFinput window
Run (via the Job → Run command in ADFjobs

When the run is complete:

Open ADFlevels using the SCM → Levels command
In the ADFlevels window, use the View → Labels → Show command
Zoom in to the region of interest (for example using your mouse wheel)
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In the levels diagram you will observe that the HOMO (the 1E1.g) is completely filled, while the orbital below
it has a hole. You can easily see this by the color. Note that we have performed a restricted calculation, so in
effect the hole is averaged over the E orbitals.

Tutorial 11: Spin Coupling in Fe4S4 Cluster

This tutorial will help you to:

• build the structure of iron-sulfur cubane,
• control the spin coupling in multicenter radical systems in two different ways (SpinFlip and

ModifyStartPotential),
• tweak the SCF convergence in the iron-sulfur cubane case,
• visualize the distribution of spin densities in 3D.

Step 1: Create and pre-optimize the Fe4S4 cubane model

Embedded into proteins and coordinated by cysteine ligands, iron-sulfur cubanes are often used by nature in
electron transfer and catalysis. While their native structures can be extracted from protein data bank (PDB)
files, we will use ADFinput module to build a model of the Fe4S4 cubane from scratch in this example.

Start ADFinput
Select the Structure tool → Polyhedra → Cube structure:
Click anywhere in the empty structure drawing area.
This should place a cube in the building area of ADFinput.

The cube built is constructed of carbon atoms. We will now change four of these atoms to iron (Fe), and next
the remaining four atoms into sulfur (S).

Via Shift-click, select four carbon atoms in the corners of the cubane
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Use the Atoms → Change Atom Type → Fe command to change the four atoms into Fe
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In the same way, change the four remaining carbons into sulfurs.

Now you should see the Fe4S4 cubane in the structure drawing area of ADFinput. The proper coordination
to Fe atoms is important in modeling their electronic structure. In proteins, iron-sulfur cubanes are
coordinated by cysteine ligands to the Fe sites. Here, we will model these four cysteines by -SH ligands. The
procedure to add these ligands is described below.

Select all the Fe atoms
Use the Atoms → Details (Color, Radius, Mass, ...) menu command
Change the number of connectors for all Fe atoms to 4
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Switch to the Main Options panel
Add hydrogens to them using the Atoms → Add Hydrogen menu command

Select the (newly added) hydrogens
Use the Atoms → Replace By Structure → Ligands → OH menu command:

This will replace hydrogen atoms into OH ligands.
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Select one of the O atoms
Use the Select → Select Atoms Of Same Type command to select them all
Use the Atoms → Change Atom Type → S to change them into S

Pre-optimize this structure (the gear wheel tool)
Repeat pre-optimizing until the geometry has converged
(note that the iteration limit is 200 iterations, so if it halts at iteration
200 it normally is not yet converged)

Click the Symmetrize button (the star) to check the symmetry
If the symmetry is not C1, move the hydrogens around, pre-optimize again, etc,
until you get a C1 structure.
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Step 2: Obtain the solution for the high-spin (HS) state of the cubane

In Fe4S4 systems, the iron sites are commonly high-spin ferric (Fe3+, S = 2) or ferrous (Fe2+, S = 5/2). For
the present example, we will use the iron-sulfur cubane oxidation state where the two sites are ferric and the
remaining two are ferrous. This oxidation level of Fe4S4 is well-defined and occurs, for example, in
rubredoxin and high-potential iron-sulfur proteins (HIPIPs). For our model system, Fe4S4(SH)4, this implies
the total charge of -2.

The relative directions, or coupling, of the individual site spin vectors is a very important issue in obtaining
the desired density functional solution in Fe4S4, as well as many other systems which display a multi-center
radical character.

Within the common open-shell approach, the spin vectors are either parallel or antiparallel. The case when
all the spins are parallel is called high-spin (HS). Obtaining self-consisted field (SCF) solution for the HS
case is normally simpler because the program does not need to resolve the ambiguity of distribution the
sites spin vectors. While the ferromagnetic HS solution commonly does not correspond to the lowest energy
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electronic state, this solution can be used to obtain the electron density corresponding to the lower energy
spin-coupled state. In this step, we will obtain the HS solution for the iron-sulfur cubane, which will be used
later in the tutorial. The HS solution for the [Fe4S4(SH)4]2- model corresponds to S = 2 × 5/2 + 2 × 2 = 9.

Select the 'Main Options' panel
Set the total charge to -2 and spin polarization to 18 (corresponds to S =
9).
Check the unrestricted option to 'Yes'.
Run this set-up (use the name FeS_HS when saving)

ADFtail window will popup showing the progress of the job:
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On modern computers, the SCF solution for our job should be obtained within a few minutes (you should get
the 'SCF converged' message). The ADFtail snapshot above shows that the convergence has been
obtained in 28 SCF cycles.
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Step 3: Couple the spins in Fe4S4 using the SpinFlip option

While SCF solution for the high-spin (HS) state of a multi-center spin system can often be easily found, this
solution does not necessarily correspond to the lowest energy state.

To generate the solution with the desired collinear spin arrangement, one option is to use the 'SpinFlip'
concept that has been earlier introduced by L. Noodleman and coworkers. In this two step procedure:

• first the spin-unrestricted HS solution is generated with all the site spins ferromagnetically coupled
in one direction (all spins up, ↑).

• Next the α (↑) and β (↓) electron densities centered at the sites which are expected to be
antiferromagnetically coupled (spins down, ↓) to the total spin vector are exchanged for the earlier
obtained HS solution, using the SpinFlip option, and the calculation is restarted.

Because this approach often results in lowering the electronic symmetry of the system while retaining its
structural symmetry, a solution obtained in such way is often called the broken symmetry (BS) state. In such
cases you will need to make sure that your BS calculation is done with lower symmetry. In the current
tutorial this is not an issue as we have forced the structure to have no symmetry.

The concept of SpinFlip and BS state can be illustrated considering our iron-sulfur cubane case with two
ferric (Fe3+, S = 2) and two ferrous (Fe2+, S = 5/2) sites. One of the well-characterized BS states for this
level of Fe4S4 oxidation corresponds to S = (5/2 + 2) - (5/2 + 2) = 0, 2↑:2↓.

Select the ADFinput window with your FeS_HS calculation
Make sure the 'Main Options' panel is visible
Change the spin polarization from 18 to 0.

This spin polarization setting corresponds to S = 0 zero spin of the BS electronic state.

Select the 'Spin and Occupation' panel

For your information, ADFlevels will show the levels from your previous calculation. As we are not changing
the occupations this info is not needed for this tutorial.

Select the two (out of four) arbitrary Fe sites in the drawing area,
click + next to the Spin Flip on Restart For: line.
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To achieve the desired BS solution, the SpinFlip procedure should be applied to 2 out of 4 Fe sites of Fe4S4.
In the above example, we selected sites Fe(6) and Fe(8). This will instruct SpinFlip algorithm to interchange
α (↑) and β (↓) electron densities associated with these two Fe sites when the job will be restarted, changing
the HS 4↑:0↓ spin state to the BS 2↑:2↓ spin state.

The Spin Flip option only works when restarting, so set up the restart calculation from the HS results:

Select the 'Files (Restart)' panel
Close the ADFLevels window
Click folder icon in front of the 'Restart file:' field,
Select the Fe_HS.t21 file (it should already be selected, so just press the
Open button)
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The above will instruct ADF to read the converged HS solution we obtained in the previous step of the
tutorial. This solution has been saved in the Fe_HS.t21.

Use the File → Save As command to save the job as FeS_BS_SPINFLIP
Run the calculation
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As displayed in the ADFtail window, our FeS_BS_SPINFLIP job converges in 27 cycles.

Step 4: Coupling the spins using the ModifyStartPotential option

There is an alternative to SpinFlip available in ADF, which is aimed to achieve a specific spin-coupled
solution in a single calculation only. This is done using the MODIFYSTARTPOTENTIAL key in ADF: it allows
you to create a spin-polarized potential at the very start of the calculation.

Please read the page of ADF user's guide on MODIFYSTARTPOTENTIAL key prior to proceeding with this
step of the tutorial. As follows from the MODIFYSTARTPOTENTIAL description, this key allows to control
the ratio of spin-α and spin-β electrons associated with fragments via 'alpha' and 'beta' numbers. For the
purpose of the present tutorial, we will consider the four Fe sites as fragments. Apparently, 'alpha' and 'beta'
numbers will correspond to the number of spin-α and spin-β electrons, correspondingly, associated with a
Fe site.

The practical guide to obtain this BS solution via MODIFYSTARTPOTENTIAL in ADF is given below.

Open your FeS_HS calculation in ADFinput
Change the spin polarization from 18 to 0
Open the Spin and Occupations panel
Select the four Fe atoms
Click the '+' in front of 'Modify Start Potential'
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Set the alpha and beta occupations, for the four Fe atoms:
14 alpha and 10 beta
14 alpha and  9 beta
10 alpha and 14 beta
9 alpha and 14 beta

For the spin-up Fe3+, S = 2, the alpha and beta numbers would be 14 and 9, correspondingly, and for the
spin-up Fe2+, S = 5/2, these numbers are 14 and 10. For the spin-down Fe sites, alpha and beta numbers
should be apparently transposed. Also, our desired BS state for this level of Fe4S4 oxidation corresponds to
S = (5/2 + 2) - (5/2 + 2) = 0, 2↑:2↓ .

Note that SCF procedure might be problematic in this case. You should experiment how to solve the
convergence problems. First you should try with some mixing and level shifting:

Select the 'SCF Convergence Aids' panel
Set Mixing value to 0.1
Set Level Shift to 0.3 Hartree

Use the File → Save As command to Save the job as FeS_BS_MODIFYSTARTPOTENTIAL
Run your calculation

If your calculation converges, you are ready. If not, try the ARH method:

Select the 'SCF Convergence Aids' panel
Make the Mixing and Level Shift fields empty (that is, undo your previous
changes)

Select the 'SCF' panel
Select Yes for the 'Use ARH method' option
Change the maximum number of SCF iterations to 100

Save the job as FeS_BS_MODIFYSTARTPOTENTIAL (using the 'File → Save' command)
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Run your calculation (this will take some time,
but normally will converge after many iterations)

Hopefully you will be able to converge the job, to the same energy and state as the SpinFlip job.
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Thus both the SpinFlip and the ModifyStartPotential option allow you to obtain a desired Fe spin coupling
pattern in the Fe4S4 case. While SpinFlip is a two-step approach and ModifyStartPotential works as in a
single step, the SpinFlip approach shows a better performance during SCF (much better and faster SCF
convergence).

Step 5: View the spin density of the broken symmetry (BS) solutions

In the two previous steps of this tutorial, we have generated the broken symmetry (BS) solution for the
Fe4S4 cubane using alternatively the SpinFlip and ModifyStartPotential options. Here, we will analyze this
BS solution viewing the Fe spin densities using ADFview, and confirm that the spin allignment of the iron
sites is 2↑:2↓ This type of analysis can also be powerfully used during presentations and for scientific
illustrations.

Select your FeS_BS_SPINFLIP calculation in ADFjobs
Use the SCM → View menu command to activate ADFview

You should see the [Fe4S4(SH)4]2- model in the ADFview window now. We have optionally selected
FeS_BS_SPINFLIP.t21, while FeS_BS_MODIFYSTARTPOTENTIAL.t21 could also be used for this
purpose.

Use the Fields → Calculated menu command

Now, you should see the two blank tab fields right to the Field:Calculated at the bottom of the ADFview
window, separated by the minus '-' sign .

Click the left blank tab menu and select Density A → SCF check box:

ADFview will take a moment now to calculate the corresponding density for spin-α ('Density A') electrons.

Next, click the right blank tab menu and select Density B → SCF check box.

Note that the minus '-' sign separating the tabs implies that we have requested ADFview to calculate the
'spin-α - spin-β' density field. ADFview automatically assigns 'C-1' title to this field, see left to the
Field:Calculated. We will visualize this 'C-1' field using one of the available ADFview options now.

Click the Add drop-down menu and select Isosurface: Double (+/-)
In the new control line, select the Other → 1 → C-1 field

You should see now the two Fe ions surrounded by blue blobs (spin up,↑) and the other two by red blobs
(spin down,↓):
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In the same way you can also confirm that for the ferromagnetic HS case (file FeS_HS.t21), the visualization
of the spin densities would display all the four Fe site surrounded by the blobs of the same color.
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